AMBER Archive (2008)

Subject: RE: AMBER: Amber10 testing problem

From: Ross Walker (ross_at_rosswalker.co.uk)
Date: Tue May 13 2008 - 16:20:53 CDT


Hi Jenk,

Are you sure the environment is the same on the machine you are running the test on and the one you compiled on? This looks to me like the LD_LIBRARY_PATH could be different in some way between compilation and testing. Such that sander then looks in the wrong place or at a different MKL version.

You could also try compiling statically and see if that fixes the problem.

You may also simply have not had the MKL library paths added to LD_LIBRARY_PATH. Make sure you source the mkl environment setup scripts in your bashrc / cshrc. E.g. on my machine in /etc/bashrc I have:

source /opt/intel/mkl/10.0.1.014/tools/environment/mklvarsem64t.sh
export MKL_HOME=/opt/intel/mkl/10.0.1.014/

Good luck,
Ross

> -----Original Message-----
> From: owner-amber_at_scripps.edu [mailto:owner-amber_at_scripps.edu] On Behalf
> Of Cenk (Jenk) Andac
> Sent: Tuesday, May 13, 2008 12:46 PM
> To: amber_at_scripps.edu
> Subject: AMBER: Amber10 testing problem
>
> Dear Amber Community,
>
> I have just installed Amber10.serial on a Linux system. The installation
> went fine with ifort10 and MKL libraries. However, I am having some
> problems testing the sander module of Amber10. As far as I understand the
> MKL library I use seems to act weird or it just could be another bug that
> I am not aware of.
>
>
> Here are the error messages I get when I type "make test"
>
> cd circ_dna && ./Run.circdna
> MKL func load error: /home_palamut2/software/library/intel-
> mkl/lib/em64t/libmkl_vml_mc.so: undefined symbol: vmlGetErrorCallBack
> ./Run.circdna: Program error
> make: *** [test.sander.GB] Error 1
>
> and "make test.serial.QMMM"
>
> cd qmmm2/1NLN_test_diagonalizers && ./Run.1NLN_internal
> MKL func load error: /home_palamut2/software/library/intel-
> mkl/lib/em64t/libmkl_vml_mc.so: undefined symbol: vmlGetErrorCallBack
> ./Run.1NLN_internal: Program error
> make: *** [test.sander.QMMM] Error 1
>
> I would apprec─▒ate it if an AMBER professional could let me know whether
> there is a workaround for the error messages I am getting.
>
>
> regards,
>
> jenk
>
>
>
>
>
> -----------------------------------------------------------------------
> The AMBER Mail Reflector
> To post, send mail to amber_at_scripps.edu
> To unsubscribe, send "unsubscribe amber" (in the *body* of the email)
> to majordomo_at_scripps.edu

-----------------------------------------------------------------------
The AMBER Mail Reflector
To post, send mail to amber_at_scripps.edu
To unsubscribe, send "unsubscribe amber" (in the *body* of the email)
      to majordomo_at_scripps.edu